Re: Photoshop Elements installation error "requires MS Internet Explorer 4.0"

Search   Help    Register    Login   Home
Fri, 17 January 2014 20:53 Go to next message
arandall636 (Photoshop begginer)
On my Windows 7 notebook I had no problem installing direct from CD, but have struck this IE error when trying to install on a Windows 7 netbook. Registry setting are identical. I didn't really want to install Elements 10 on the netbook, but looks like I may have no choice :-(
Tue, 11 March 2014 12:10 Go to previous message
henrik.skogwik (Photoshop begginer)
This is how I did it.
I'm on Windows 7 (64bit), IE11 installed.
When I checked the registry all the paths were already there.
I took a copy of iexplore.exe from a computer running XP and IE8.
I created the following path "C:\Program Files\Internet\" and put the IE8 iexplore.exe there.
Then I temporarily changed the default string in the registry to "C:\Program Files\Internet\iexplore.exe" and the path string to "C:\Program Files\Internet Explorer: "
I had to use a different path because I couldn't change the name on the current iexplore.exe to temporarily use the old one.

I then ran the setup without any problem. After the installation was completed I changed back to the original values in the registry.

I think the problem is that Photoshop Elements doesn't read the version of IE correct.
I know this requires access to a copy of and older version of iexplore.exe, but a thought I'll let you know how I did it.

I hope this helps!
Create a new topic Submit Reply
Goto Forum:

Adobe Photoshop

Adobe Photoshop techniques & help
Photoshop for Windows
Photoshop for Mac
Technical questions

Photoshop Elements

Adobe Photoshop Elements